3.0 and Java 1.6

Problem reports, Questions and Feedback report in here
User avatar
nmeier
Site Admin
Posts: 2159
Joined: Mon Feb 02, 2004 21:35:23
Location: Toronto, Canada
Contact:

3.0 and Java 1.6

Postby nmeier » Mon Jan 18, 2010 23:17:09

Hi

GenJ 3.0 requires Java 1.6 - here are some tips on getting it

for Windows, Linux, Solaris get it here

for Mac OS X 10.4/5 32Bit get it here and follow this tip

for Mac OS X 10.5 on a 64-bit get it here

(*Apparently some manual work makes Macs finally switch their default VM over to 1.6 - read more here)

Hope that helps

Cheers
Nils

riegelstamm
Posts: 2
Joined: Fri Feb 05, 2016 18:26:40

Re: 3.0 and Java 1.6

Postby riegelstamm » Fri Feb 05, 2016 18:37:49

The Prerequisites say that "The prerequisite for running GenJ on your operating system is a Java Virtual Machine version 1.6 or higher." I have Java 1.8 on my Mac, but when I try to run GenJ, I get this message: "To open “GenealogyJ” you need to install the legacy Java SE 6 runtime." Java 1.6 was deprecated quite some time ago, and soon 1.9 will be released. There must still be some 1.6 dependencies in GenJ. Does anyone plan to rebuild GenJ for Mac using 1.8?
Attachments
Screen Shot 2016-02-05 at 4.36.16 PM.png
Java 1.6 REQUIRED on Mac
Screen Shot 2016-02-05 at 4.36.16 PM.png (28.23 KiB) Viewed 627 times

User avatar
nmeier
Site Admin
Posts: 2159
Joined: Mon Feb 02, 2004 21:35:23
Location: Toronto, Canada
Contact:

Re: 3.0 and Java 1.6

Postby nmeier » Fri Feb 05, 2016 21:15:14

Hi
If i remember correctly there's nothing code wise depending on 1.6, there must be something in the descriptor file that is not good here making mac think =1.6 rather than >=1.6

You could open up the archive and check inside, iirc there's an xml file in there with settings

Nils

Tranas
Posts: 37
Joined: Mon May 24, 2010 12:29:03

Re: 3.0 and Java 1.6

Postby Tranas » Sun May 08, 2016 8:21:04

Nils -

Seems that there may be issues not only with 1.6
After update to jre-8u91-windows-i586 on a Win10 machine, GenJ throws an error and will not start.

Same machine with 8u77 did not have the issue.
Attachments
GenJ-error.jpg
GenJ-error.jpg (22.03 KiB) Viewed 528 times

User avatar
nmeier
Site Admin
Posts: 2159
Joined: Mon Feb 02, 2004 21:35:23
Location: Toronto, Canada
Contact:

Re: 3.0 and Java 1.6

Postby nmeier » Fri Jun 24, 2016 23:23:12

Hi Tranas

That last screenshot is from Windows? I have Windows 10, updated to the latest. With Alex's change from late April GenJ requires 1.8/9 and detects it without problem over here.

I'm not sure where this message comes from - try to run genj via

java -jar run.jar

from the GenJ installation folder (or where you've unzipped it).

Nils

Tranas
Posts: 37
Joined: Mon May 24, 2010 12:29:03

Re: 3.0 and Java 1.6

Postby Tranas » Fri Nov 04, 2016 7:50:44

Hi Nils,

Sorry about the long response time... This was not directly a GenJ issue - but it effects users of GenJ on Win10 in some circumstances.
Win10 is not as flexible as Win7 when it comes to moving links and icons to the taskbar. If you want to place a GenJ link in the taskbar and/or change the icon that is displayed with the link, you need to create an exe file that 'wraps' the run.jar. I use a cross-platform Java executable wrapper tool called Launch4j. http://launch4j.sourceforge.net/ This way, I get the link location and the icon that I prefer.
When creating the 'wrapper' using Launch4j you designate the version range which applies. If you update to a newer JAVA version and click on the taskbar link, the message I posted is thrown and the taskbar link no longer works. Simply create a new executable and you are back in business.
Attachments
Launch4jSnip.jpg
Launch4jSnip.jpg (109.68 KiB) Viewed 353 times


Return to “Support - Feedback and Help in English”

Who is online

Users browsing this forum: No registered users and 1 guest